Fuel cells

The DMFC use methanol as a liquid energy carrier instead of hydrogen. The DMFC works as the PEM fuel cell with the difference that at the anode the methanol is converted into carbon dioxide, protons and electrons. The reaction requires a special catalyst alloy of platinum/ruthenium molecules on a carbon substrate.

Schematic presentation of DMFC fuel cell components

IRD Direct Methanol Fuel Cells

The IRD Direct Methanol Fuel Cells are constructed with separate water and fuel circuits. The bipolar flow plates are for corrosion reasons made of a special graphite/carbon polymer material.

IRD Direct Methanol Fuel Cell

Direct Methanol Fuel Cell developed by IRD Fuel Cells A/S, Denmark

0,7 kW IRD Direct Methanol Fuel Cell

IRD Direct Methanol Fuel Cells stack specifications

  • Active cell area: 156 cm2
  • Active cell area dimension: 125mm x 125mm
  • Fuel: methanol/air
  • Max fuel pressure: 1.5 bar
  • Cell voltage nominal: 0.5 V
  • Cell current density nominal: 0.2 A/cm2
  • Cell power density: 100 mW/cm2
  • Unit cell power: 15 W/cell