How a Tesla Coil works

On this page, I will explain the basic theory of how a Tesla coil works. Below is the Table of Contents for this page.

  • Description of Components
  • How the Components Operate
  • LC Circuits
  • Resonant Rise
  • Oscillation and Tuning

Description of Components

A Tesla coil is a high-voltage air-core resonant transformer. A Tesla coil has 6 basic components. The first is the primary transformer which is a high-voltage iron-core transformer. The second is the tank capacitor which is a high-voltage capacitor that is usually homemade, but can be purchased for a high price from certain companies. The third is the spark gap, basically two wires separated by a small gap of air. The fourth is the primary coil consisting of about 10 to 15 turns of thick heavy gauge wire wound around the base of the secondary coil. The fifth is the secondary coil, and it consists of many hundreds of turns of relatively thin, small gauge enameled wire. The primary and secondary coils make up an air-core transformer. That means that there is no iron core inside of the coils. The sixth basic component is the toroid. It is a doughnut shaped object that is usually covered with aluminum tape, and placed on top of the secondary coil. The high-voltage sparks radiate in all directions from the toroid out into the air.

How the Components Operate

The primary transformer converts the AC line voltage (120/240 volts AC) to over 10,000 volts. This energy is used to charge the high-voltage capacitor. The capacitor is wired in parallel with the output of the transformer. When there is enough energy stored in the capacitor to arc across the distance of air in the spark gap, a spark will bridge the spark gap and complete the circuit to the primary coil. A spark ionizes the air, causing it to become much more conductive. All the energy stored in the capacitor will be forced through the primary coil. The process of charging the capacitor and firing the spark gap occurs very rapidly. The spark gap may fire from 120 to over 1000 hertz, but 120 hertz is the most efficient rate for maximum spark length. When the energy is transferred to the primary coil, an electromagnetic field is generated and surrounds the secondary coil. The secondary coil absorbs this energy and magnifies the voltage further. The resulting voltage could be a couple hundred thousand volts for small coils, or millions for very large ones. It is very important to efficiently ground the coil. Grounding the coil gives it electrical leverage against the earth to radiate its energy from the toroid. The bottom wire of the secondary coil is grounded via a heavy gauge wire that leads directly to a ground rod. The top wire of the secondary is connected to the toroid. There should usually be a couple inches between the top winding of the secondary and the toroid.

A schematic diagram of a Tesla coil.

LC Circuits

Tesla coils are composed of two resonant LC circuits. Both of those resonant circuits must be tuned to the exact same frequency for optimum efficiency. The first resonant circuit is the tank circuit. The tank circuit is composed of the capacitor, spark gap, and primary coil. The second resonant circuit is the secondary coil and the toroid.
An LC circuit contains an inductor (a coil) and a capacitor respectively. An LC circuit is at resonance when the inductive reactance of the inductor equals the capacitive reactance of the capacitor at the same frequency. Reactance is the resistance to the AC waveform. Another way to define reactance, is the resistance to any change in voltage or current flow from the current instantaneous value. Alternating current is constantly changing because it flows in the form of a sine wave. Inductors resist changes in current flow and capacitors resist changes in voltage. Reactance is not the same as simple DC resistance. DC resistance is the resistance to the flow of electrons through a material, not the resistance to changes in voltage or current. The reactance of a capacitor or an inductor is based upon its value, and the frequency at which it operates. Finding the reactance of a component is explained on the calculations page. The graphic below shows the relationship between frequency, reactance, and resonant frequency. Capacitive reactance is denoted XC and inductive reactance is denoted XL.

For any two given values of L and C their reactances will only be equal at one frequency. In a shock excited oscillator such as the tank circuit, the circuit will resonate at that frequency where the reactances are equal. The circuit resonates at that frequency because the circuit is balanced at that frequency. When the reactances are equal, both components have an equal charge and discharge time delay. It takes the inductor the same amount of time to discharge into the capacitor as it did for the capacitor to discharge into the inductor. The amount of time it takes for the discharge cycles to complete determines the number of cycles per second, which is the frequency of the oscillator circuit.
The toroid is actually one plate of a virtual capacitor. The second plate of the virtual capacitor is the earth itself, because the bottom wire of the secondary coil is grounded. The larger the toroid, the more capacitance it has. The toroid must have the right amount of capacitance, so that its reactance equals the secondary coil's inductive reactance at the coil's predetermined resonant frequency. The secondary circuit is also a shock excited oscillator like the tank circuit. The secondary coil itself also has capacitance. The wire of the coil has capacitance, and there is capacitance between each turn of the coil. Although these capacitances are extremely minute, at high frequencies they become quite significant. These effects on the circuit are discussed in more detail on the calculations page.

These graphics show the distribution of capacitance throughout the secondary circuit.

Resonant Rise

Tesla coils are resonant transformers. That means that the secondary coil achieves much of its voltage gain through resonant rise. In standard iron-core coupled transformers, the turns ratio is the factor in the change of voltage, but a Tesla coil is a resonant transformer. The two resonant circuits in a Tesla coil must be properly tuned to allow the coil to operate at maximum efficiency.
Resonant rise is what causes the tremendous voltage gain in the secondary coil. Resonant rise occurs in a series LC circuit when the frequency of the AC waveform that feeds the circuit is equal to the resonant frequency of the LC circuit.
Note that power in equals power out. The gain in voltage is a result of the sacrifice of current. Tesla coils do not produce "free energy", but they are efficient when tuned properly.
The inductive and capacitive components in a circuit cause a phase shift between the waveform of the current flowing through the component and the voltage drop across the component. In a purely resistive circuit, the current is in phase with the voltage. As the input voltage to the resistor increases, so does the current flowing through it (Ohm's law).

In a purely inductive circuit, the current waveform lags the voltage waveform by 90°, 1/4 of the sine wave. Another way to state that is that the voltage waveform leads the current waveform by 90°.

In a purely capacitive circuit, the current leads the voltage, or the voltage wave lags the current wave by 90°.

In a circuit containing a combination of resistance and capacitance or inductance, the phase angle between the voltage and current waveforms of the entire circuit is some number less than 90°, depending on the component values. The total impedance and the phase angle of an LCR circuit is found by vector addition, but this is beyond the scope of this page. In a tuned resonant circuit, the reactive components have a canceling effect, and the phase angle is zero (the waveforms are in phase). A Tesla coil only contains tuned resonant circuits, and therefore phase angles other than zero are not practically existent Tesla coils.
In a parallel LC circuit, the voltage drops of all components are in phase and equal, while the current waveform of each component is out of phase (by 90°), and the magnitude of those waves may differ. In a series LC circuit, the current waveform flowing through the entire circuit remains constant, and the voltage drops of the L and C components are out of phase with the current. The magnitude of the voltage drops may vary. Tesla coils only contain series resonant circuits. Although the oscillator components in the primary and secondary circuits are wired in parallel; since they are oscillator circuits, the charged component acts as a voltage source while the uncharged component acts as a load. This is considered a series circuit, however resonant rise does not occur in the tank circuit. This is because a voltage source is not present in series with the L and C components.

A Parallel LC circuit. | A series LC circuit.

The voltage drop of a component is the voltage potential that exists on the two leads of the component. The voltage drop of an L or C component is found by multiplying its reactance by the current flowing through it (Ohm's law). In a series circuit at resonance, the reactances of the components, and therefore the voltage drops are equal. The current waveform is the same for each component, and the capacitor voltage lags it by 90°, and the inductor voltage drop leads it by 90°. Therefore, the voltage drops are exactly opposite (180° out of phase), and equal in magnitude. This causes the reactive loads in the series resonant circuit to exactly cancel each other out. This allows the maximum amount of current possible to flow through the circuit unrestricted by the reactive components. The only impedance that limits current flow remaining in the series circuit is the DC resistance of the wire the inductor is wound from. An inductor always contains some value of resistance in its wire, and some value of inductive reactance (based on the inductance value), and these two impedance's act in a series configuration.

Since the resistance of the inductor's wire is the only resistive component acting in the series circuit, a great amount of current flows through the entire circuit. This high current value multiplied by the impedance of the inductor or capacitor is equal to the voltage drop at the terminals of that component. If the circuit is at perfect resonance, then the voltage drops of both the inductor and capacitor will be equal and at a maximum. This voltage drop can be many times greater than the voltage applied to the circuit, depending on multiple factors.

The voltage drop, or resonant rise is equal to QE, the quality factor of the inductor multiplied by the voltage applied to the series circuit. Q is given by the ratio of inductive reactance to the DC resistance of the wire the coil is would from. The higher the Q value, the better. A low Q is not acceptable and it allows the secondary coil to have a very large tolerance as to the frequency it has been tuned to. This frequency tolerance is known as band width. A high Q keeps the coil from floating around into other frequencies. A high Q also increases the efficiency of the resonant circuit and resonant rise. This is why the Q of the secondary coil is so important. A higher Q means higher resonant rise, within certain design limitations.

This graphic shows the current flow in a series LCR circuit in relation to the frequency of the voltage waveform applied to it. At the resonant frequency, current is at its peak and so are the voltage drops of the L and C components.

The secondary coil and toroid form a shock-excited oscillator that resonates at the frequency where the reactances are equal, but this does not cause resonant rise. The resonant rise in the secondary circuit is caused by the oscillation of the primary coil inducing energy into the secondary coil. Because of the way the primary and secondary coils are loosely coupled, they do not behave in the same way as a normal iron-core transformer. The induced energy in the secondary coil acts as a voltage source placed in series with the secondary coil and toroid capacitor. This causes resonant rise in the secondary circuit. The primary coil also continuously reinforces the oscillation in the secondary coil. The primary coil (tank circuit) must be tuned to resonate at exactly the resonant frequency of the secondary circuit for maximum efficiency.

This graphic shows the induced voltage as an AC source to the secondary series resonant circuit.

Oscillation and Tuning

The output waveform of a Tesla coil that is commonly referred to as "ringing" is caused by the oscillatory response of the tank circuit and secondary resonant circuit. Oscillation is the process where an interchange of energy takes place between the inductor and the capacitor in a tuned resonant circuit. This oscillation is caused by shock-exciting the LC circuit by means of the spark gap.
The firing of the spark gap is the electrical equivalent to striking the side of a bell with a hammer. The LC circuit is like the bell. A bell, when struck, will ring at a particular musical tone. The size and shape of the bell determine the frequency of its tone, just like the capacitance and inductance of a circuit determine the frequency of the circuit. The tank circuit will continue to "ring" for as long as the arc across the spark gap lasts or the circuit runs out of energy.
When the capacitor is charged to its peak voltage, the spark gap fires. The capacitor then discharges its energy into the primary coil. The capacitor starts off at its peak voltage and is discharged to zero volts, forming 1/4 cycle of the tank circuit's resonant frequency. As the capacitor is being discharged, the voltage drop is decreasing and current flowing through the circuit is increasing, causing field strength of the primary coil to rise. The primary coil stores this energy in the form of its electromagnetic field. When the current flowing through the primary coil reaches its peak and the capacitor voltage is zero (because the capacitor is drained), current flow begins to fall because the capacitor can no longer supply current. The primary coil resists this decrease in current flow by producing back emf (electromotive force). Back emf is caused by the collapsing of the coil's magnetic field as the current flowing through it drops. A coil's magnetic field is sustained by current flow. The back emf voltage is of the opposite polarity of the capacitor, causing current to flow in the same direction. The primary coil charges the capacitor with its emf at the opposite of the capacitor's original polarity. Now that the capacitor is charged at the new polarity, it also discharges into the primary coil at that new polarity, causing the electromagnetic field of the primary coil to change polarity. As the emf energy stored in the capacitor drops to zero, the primary produces back emf again at the opposite of the capacitor's polarity. This causes the capacitor to be charged at its original polarity, and the cycle repeats itself. The oscillations continue to repeat until the spark gap is quenched, or the circuit runs out of energy.
This back and forth recycling of energy can be compared to the swinging of a pendulum. The pendulum starts off in neutral position, pointing straight up and down. When it is pushed left it swings to the left until it peaks, and then swings back to the right. It goes past the neutral position, peaks, and swings back to the left again. It continues swinging, traveling a little less distance each cycle until it runs out of energy or is stopped.
Below is a graphic of how oscillation works. The diagram shows the polarity of charge, the direction of current flow, and pieces of the current flow wave generated by each part of the cycle. The sine wave shown is in relation to the flow of current when oscillation begins.

The output result of the oscillations is a damped sine wave. Like the pendulum analogy, each cycle is weaker in magnitude than the previous. The decreasing of each cycle is caused by losses within the components of the LC circuit. The voltage and current waveforms in the circuit both decrease. These losses occur because of the resistance of the wire in primary coil, not its impedance (inductive reactance), and the dissipation factor of the capacitor. For the tank capacitor, you should use a very low loss dielectric, "leaky" capacitors waste energy. The copper conductor of the primary coil offers significant resistance because of the skin effect. At high frequencies, electricity flows over the surface of a conductor more than through it. The electrical current may only penetrate the conductor by a few mils. The solution to this problem is to use a conductor with maximum surface area. Below is a graphic of the damped sine wave produced in the tank circuit and from the output of the Tesla coil. If there were no losses within the circuit, the oscillations would continue indefinitely and there would not be a dampening effect, but such a condition does not exist.

Damped sine wave graphic.

It is very important for the primary coil to resonate at the same frequency as the secondary coil so that each pulse from the ringing of the primary is in sync with the secondary coil. This situation is like pushing a swing set. You must give the swing a push at the same frequency that it is moving back and forth in order to maintain its motion. If the swing is flying toward you and you give it a push before it is ready to go back the other way, the you will cancel out the motion and the swing will stop.
The secondary resonant circuit of the secondary coil and toroid is also a shock-excited oscillator. Although the secondary circuit is magnetically induced with the primary circuit's energy, the secondary circuit can ring at a different frequency that is independent of the primary circuit. The oscillatory response of the secondary circuit operates in the same manner as in the primary circuit. The difference in the secondary circuit is that its initial excitation source is the primary coil. After the initial pulse from the tank circuit, the secondary circuit oscillates at the frequency it has been tuned to (where the coil's reactance equals the toroid's reactance). Throughout the oscillations, the primary coil reinforces the oscillation of the secondary circuit and the secondary oscillation reinforces the resonant rise current induced into it by the primary. This is why it is absolutely critical that the primary circuit should resonate at the same frequency as the secondary circuit. Just as the circuits reinforce each other when they are in tune, they can cancel out the resonant rise in the secondary circuit if they are out of tune.
For example, the secondary coil and toroid are tuned to be resonant at 100 kilohertz. If the primary is inducing the secondary coil at 120 kilohertz, then the frequencies are not in sync. At 120 kilohertz, the secondary series circuit is not resonant, and so resonant rise will be severely decreased. Also, instead of the primary coil reinforcing the oscillation of the secondary coil, the two waveforms have a canceling effect on the secondary circuit and further cancel out resonant rise. This has a major effect on the output of the Tesla coil. Below is a graphic of the voltage waveforms of the two resonant circuits in tune.

The waveforms are in perfect synchronization, resonant rise is at its peak, and the output is at its maximum. The rapid and then gradual decrease in output is caused by the component losses in the oscillator circuits. The circuit is delivering the maximum voltage output at a steady rate.
Below is a graphic of the primary circuit resonating at a higher frequency than the secondary circuit.

Notice the drastic changes in output voltage as the sine waves phase in and out of sync. When the sine waves are out of sync, resonant rise voltage is shorted out and wasted by the existing secondary circuit oscillation. Resonant rise is also decreased from the start, because of the wrong frequency being induced into the secondary circuit. The efficiency of the circuit fell rapidly and fluctuated, causing a decrease in overall delivered power.

It is critical to the efficiency of a Tesla coil to have all the components properly in tune with each other. Having just a little too much or too less of any electrical value can have a drastic effect on the output of your coil. The calculations page explains the steps involved in designing an efficient, tuned Tesla coil and finding the necessary values for each component.

Back to homepage.

Copyright © 1998, Matt Behrend, All Rights Reserved.