В сканирующем тунельном микроскопе (СТМ) , созданном впервые в 81-ом году в швейцарском отделении IBM, острие металлического электрода располагают на расстоянии в несколько ангстрем от исследуемой поверхности. Между поверхностью и острием прикладывают напряжение. Возникающее в результате электрическое поле заставляет электроны туннелировать сквозь воздушный зазор. Тунельный ток, достигающий величины в несколько микроампер, испытывает резкие изменения в зависимости от расстояния до поверхности. Зонд перемещают вдоль поверхности при помощи пьезоподвижки. В результате вариации тока повторяют рельеф поверхности над которой прошла игла зонда. Для увеличения динамического диапазона СТМ, обеспечения линейности его отклика и предотвращения электрического пробоя между иглой и поверхностью в систему добавляют обратную связь, которая регулируя расстояние между иглой и поверхностью образца удерживает постоянной величину тунельного тока. С помощью СТМ удаётся не только видеть отдельные атомы, но и перемещать их.

Однако только с создания в 1986 г. атомно-силового микроскопа (АСМ), позволяющего, в отличие от туннельного микроскопа, осуществлять взаимодействие с любыми материалами, а не только с проводящими, открылась перспектива создавать нанотехнические устройства. Дело в том, что для столь маленьких механизмов, классическая технология не приемлема и приходится опираться на разработки самой природы, которая, как известно, предпочитает углерод и органику. В АСМ исполльзуется сверхтонкая игла, закреплённая консольно над исследуемой поверхностью как показано на анимации. Между незаряженной иглой и исследуемой поверхностью возникает силовое взаимодействие, основной вклад в которой дают силы отталкивания, вызванные механическим контактом крайних атомов зонда и образца, силы Ван-дер-Ваальса, а также капиллярные силы, связанные с наличием пленки адсорбата (воды) на поверхности образца. При сканировании баланс сил взаимодействия зонда и образца приводит к изгибу упругой консоли; величина которого детектируется прецизионным датчиком. В большинстве атомно-силовых микроскопов для этого используют оптические датчики. Использование волоконно-оптического интерферометра Фабри-Перо (волоконно-оптического ИФП) позволяет детектировать смещение консоли с разрешением в несколько ангстрем, что повышает чувствительность АСМ. Помимо этого само оптическое волокно имеет диаметр около 100 микрон, что делает чувствительный элемент АСМ чрезвычайно миниатюрным. На анимации показан принцип работы АСМ с волоконно-оптическим ИФП. При сканировании поверхности упругая консоль с иглой испытывает изгибы, которые повторяют рельеф поверхности. Смещения иглы регистрируются по смещению "рабочей точки" ИФП (расстояния между отражателями интерферометра - поверхностью консоли и торца волокна, частично отражающего свет назад в волокно на границе раздела с воздухом). В результате свет, возвращаемый в волокно и регистрируемый фотодетектором, испытывает вариации, повторяющие рельеф силового воздействия иглы с поверхностью образца.

Для обеспечения линейности отклика АСМ с ИФП и расширения его динамического диапазона волокно и зонд устанавливают на прьезоподвижку, которая под воздействием регулирующего сигнала может изменять расстояние до исследуемой поверхности. Сигнал рассогласования интерферометра через управляющую схему подаётся на пьезоподвижку и таким образом достигается постоянство расстояния от зонда до поверхности и, соответственно, от упругой консоли до торца волокна. Чувствительный элемент, состоящий из зонда и волокна, перемещается над поверхностью, повторяя её рельеф. Сигнал с пьезоподвижки вертикального перемещения может служить выходным сигналом АСМ, т.к. он пропорционален величине атомно-силового взаимодействия между образцом и зондом.

Ещё одна модификация АСМ с волоконно-оптическим ИФП, наиболее активно используемая в настоящее время - АСМ резонансного типа (tapping mode). В этой схеме дополнительный пьезоэлемент возбуждает вынужденные колебания консоли на его резонансной частоте (вдали от поверхности образца). При сближении зонда и образца возникновение дополнительного градиента сил их взаимодействия приводит к сдвигу резонансной частоты (изменению эффективной жесткости) и частичному выходу системы из резонанса, что уменьшает амплитуду колебаний. При сканировании АСМ в резонансном режиме система обратной связи поддерживает на заданном уровне величину амплитуды колебаний. В силу высокой чувствительности амплитуды колебаний к среднему значению расстояния между зондом и образцом, можно получать информацию о топографии поверхности с достаточно высоким пространственным разрешением.

И, наконец, топографию исследуемой поверхности можно сканировать при помощи самого волоконного световода. При этом поверхность должна быть однородно отражающей и не иметь сильных шероховатостей. При таком подходе частично отражающий торец волокна и исследуемая поверхность под волокном образуют интерферометр Фабри-Перо. Волокно поставлено на пьезокерамику. Цепь обратной связи поддерживает постоянным расстояние между волокном и поверхностью образца. При определённых типах поверхности и её рельефа такая конструкция может быть использована для её сканирования, однако в общем случае вариации коэффициента отражения поверхности будут интерпретироваться системой как изменения ей топографии.