Test of the Powerball

created on December 7, 2003 - JLN Labs - Last update December 7, 2003

The Powerball is a very interesting and an unique device which uses the gyroscopic precession force and the power of the hand to self-energize itself. The Powerball is able to turn at a very high speed ( > 10000 RPM ) and becomes bright while it runs. I have tested myself this device. Today, I can say that this device is worth really to be tested by anyone.
I am very gratefull to Samy Bensmida for giving me the privilege to test such a device.

The Powerball Neon Blue version. A small computer is placed on the top.

You may see the main gyroscope (yellow) and the electronic board
The small computer is able to display :
1) The real time turn speed,
2) the highest RPM,
3) the number of turns during 30 seconds.

The Powerball is patented (